summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c8aabc5afe..d0ff14fa2f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3921,6 +3921,10 @@ if test x"$with_ads_support" != x"no"; then
LIBS="$ac_save_LIBS"
fi
+if test x"$use_ads" != xyes; then
+ merged_build_possible=no
+fi
+
AC_CHECK_LIB_EXT(nscd, NSCD_LIBS, nscd_flush_cache)
PASSDB_LIBS="$PASSDB_LIBS $NSCD_LIBS"
@@ -6361,6 +6365,11 @@ AC_ARG_ENABLE(merged-build,
[AS_HELP_STRING([--enable-merged-build], [Build Samba 4 as well])],
[ enable_merged_build=$enableval ], [ enable_merged_build=auto ])
+if test x"$enable_merged_build" = x"yes" -a \
+ x"$merged_build_possible" = x"no" ; then
+ AC_MSG_ERROR(Merged build required but not possible)
+fi
+
m4_include(../lib/zlib/zlib.m4)
if test x$enable_merged_build = xauto; then