summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in25
1 files changed, 22 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b5d4d881e0..252c6d7006 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1885,7 +1885,7 @@ fi
# If we don't have all of these then disable large
# file support.
#
-echo "checking if large file support can be enabled"
+AC_MSG_CHECKING([checking if large file support can be enabled])
AC_TRY_COMPILE([
#if defined(HAVE_LONGLONG) && (defined(HAVE_OFF64_T) || (defined(SIZEOF_OFF_T) && (SIZEOF_OFF_T == 8)))
#include <sys/types.h>
@@ -1896,10 +1896,10 @@ __COMPILE_ERROR_
[int i],
samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT=yes,samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT=no)
if test x"$samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT" = x"yes"; then
- echo "yes"
+ AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_EXPLICIT_LARGEFILE_SUPPORT)
else
- echo "no"
+ AC_MSG_RESULT(no)
fi
AC_ARG_WITH(spinlocks, [ --with-spinlocks use spin locks instead of fcntl locks ])
@@ -1925,6 +1925,25 @@ if test "x$with_spinlocks" = "xyes"; then
esac
fi
+#################################################
+# check for POSIX ACL support
+
+AC_MSG_CHECKING(whether to support POSIX ACLs)
+AC_ARG_WITH(posix-acls,
+[ --with-posix-acls Include POSIX ACL support
+ --without-posix-acls Don't include POSIX ACL support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_POSIX_ACLS)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
echo "checking configure summary"
AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
echo "configure OK";,