summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in33
1 files changed, 16 insertions, 17 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 44f4288a74..8154aabcc6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -52,23 +52,6 @@ if test x"$samba_cv_volatile" = x"yes"; then
fi
-#################################################
-# set codepage directory location
-AC_ARG_WITH(codepagedir,
-[ --with-codepagedir=DIR Where to put codepage files (\$libdir/codepages)],
-[ case "$withval" in
- yes|no)
- #
- # Just in case anybody does it
- #
- AC_MSG_WARN([--with-codepagedir called without argument - will use default])
- ;;
- * )
- codepagedir="$withval"
- ;;
- esac])
-
-
AC_CANONICAL_SYSTEM
dnl Add #include for broken IRIX header files
@@ -327,6 +310,22 @@ fi
AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])
+
+############################################
+# check if the compiler can do immediate structures
+AC_CACHE_CHECK([for immediate structures],samba_cv_immediate_structures, [
+ AC_TRY_COMPILE([
+#include <stdio.h>],
+[
+ #define X_FOOBAR(x) ((FOOBAR) { x })
+ typedef struct {unsigned x;} FOOBAR;
+ FOOBAR f = X_FOOBAR(1);
+],
+ samba_cv_immediate_structures=yes,samba_cv_immediate_structures=no)])
+if test x"$samba_cv_immediate_structures" = x"yes"; then
+ AC_DEFINE(HAVE_IMMEDIATE_STRUCTURES)
+fi
+
############################################
# check for unix domain sockets
AC_CACHE_CHECK([for unix domain sockets],samba_cv_unixsocket, [