summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 19355d4158..bd7a31f25d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1605,8 +1605,9 @@ for i in $LOOK_DIRS ; do
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="$CPPFLAGS -I$i/include"
dnl This is here to handle -withval stuff for --with-libiconv
-dnl Perhaps we should always add a -L
- LDFLAGS="-L$i/lib"
+ if test x"$ICONV_PATH_SPEC" = "xyes" ; then
+ LDFLAGS="-L$i/lib"
+ fi
LIBS=
export LDFLAGS LIBS CPPFLAGS
dnl Try to find iconv(3)
@@ -1615,6 +1616,7 @@ dnl Try to find iconv(3)
if test "$ICONV_FOUND" = yes; then
LIB_ADD_DIR(LDFLAGS, "$i/lib")
CFLAGS_ADD_DIR(CPPFLAGS, "$i/include")
+ LIBS="$save_LIBS"
ICONV_LOCATION=$i
export LDFLAGS LIBS CPPFLAGS
dnl Now, check for a working iconv ... we want to do it here because