summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in36
1 files changed, 20 insertions, 16 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e55114de15..4def9cd80a 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2766,22 +2766,26 @@ AC_CHECK_FUNCS(getpagesize)
# look for a method of setting the effective uid
seteuid=no;
-case "$host_os" in
-*linux*)
-if test $seteuid = no; then
-AC_CACHE_CHECK([for Linux thread-specific credentials],samba_cv_USE_LINUX_THREAD_CREDENTIALS,[
-AC_TRY_RUN([
-#define AUTOCONF_TEST 1
-#define USE_LINUX_THREAD_CREDENTIALS 1
-#include "${srcdir-.}/../lib/util/setid.c"
-#include "${srcdir-.}/lib/util_sec.c"],
- samba_cv_USE_LINUX_THREAD_CREDENTIALS=yes,samba_cv_USE_LINUX_THREAD_CREDENTIALS=no,samba_cv_USE_LINUX_THREAD_CREDENTIALS=cross)])
-if test x"$samba_cv_USE_LINUX_THREAD_CREDENTIALS" = x"yes"; then
- seteuid=yes;AC_DEFINE(USE_LINUX_THREAD_CREDENTIALS,1,[Whether we can use Linux thread-specific credentials])
-fi
-fi
-;;
-esac
+#
+# Disable for now until Linux-64 and Linux-32 specific versions
+# are separated out.
+#
+#case "$host_os" in
+#*linux*)
+#if test $seteuid = no; then
+#AC_CACHE_CHECK([for Linux thread-specific credentials],samba_cv_USE_LINUX_THREAD_CREDENTIALS,[
+#AC_TRY_RUN([
+##define AUTOCONF_TEST 1
+##define USE_LINUX_THREAD_CREDENTIALS 1
+##include "${srcdir-.}/../lib/util/setid.c"
+##include "${srcdir-.}/lib/util_sec.c"],
+# samba_cv_USE_LINUX_THREAD_CREDENTIALS=yes,samba_cv_USE_LINUX_THREAD_CREDENTIALS=no,samba_cv_USE_LINUX_THREAD_CREDENTIALS=cross)])
+#if test x"$samba_cv_USE_LINUX_THREAD_CREDENTIALS" = x"yes"; then
+# seteuid=yes;AC_DEFINE(USE_LINUX_THREAD_CREDENTIALS,1,[Whether we can use Linux thread-specific credentials])
+#fi
+#fi
+#;;
+#esac
if test $seteuid = no; then
AC_CACHE_CHECK([for setreuid],samba_cv_USE_SETREUID,[