summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c5775f810c..4c2a3620d0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6172,15 +6172,18 @@ fi
if test x"$enable_pthreadpool" = x"yes" -a x"$samba_cv_HAVE_PTHREAD" = x"yes"; then
LIBS="$LIBS $PTHREAD_LDFLAGS"
CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
- AC_DEFINE(WITH_PTHREADPOOL, 1, [Whether to include pthreadpool helpers])
AC_SUBST(PTHREADPOOL_OBJ, "lib/pthreadpool/pthreadpool.o")
- PTHREADPOOLTEST="bin/pthreadpooltest"
- AC_SUBST(PTHREADPOOLTEST)
if test x"$samba_cv_HAVE_AIO" = x"yes"; then
default_shared_modules="$default_shared_modules vfs_aio_pthread"
fi
+else
+ AC_SUBST(PTHREADPOOL_OBJ, "lib/pthreadpool/pthreadpool_sync.o")
fi
+AC_DEFINE(WITH_PTHREADPOOL, 1, [Whether to include pthreadpool helpers])
+PTHREADPOOLTEST="bin/pthreadpooltest"
+AC_SUBST(PTHREADPOOLTEST)
+
#################################################
# Check to see if we should use the included iniparser