summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f6483c6d30..3c8b2712e9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6,6 +6,7 @@ dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
AC_SUBST(SHELL)
+AC_SUBST(MPROGS)
AC_PROG_AWK
AC_CANONICAL_SYSTEM
@@ -525,6 +526,27 @@ AC_ARG_WITH(automount,
)
#################################################
+# check for smbmount support
+AC_MSG_CHECKING(whether to use SMBMOUNT)
+AC_ARG_WITH(smbmount,
+[ --with-smbmount Include SMBMOUNT (Linux only) support
+ --without-smbmount Don't include SMBMOUNT support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_SMBMOUNT)
+ MPROGS="bin/smbmount bin/smbmnt bin/smbumount"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ MPROGS=
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+ MPROGS=
+)
+
+#################################################
# check for a LDAP password database
AC_MSG_CHECKING(whether to use LDAP password database)
AC_ARG_WITH(ldap,