summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 3 insertions, 5 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4d3db00e40..6a26038d68 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6258,19 +6258,17 @@ fi
# Check if user wants pthreadpool support
AC_ARG_ENABLE(pthreadpool,
-[AS_HELP_STRING([--enable-pthreadpool], [Enable pthreads pool helper support (default=no)])])
+[AS_HELP_STRING([--enable-pthreadpool], [Enable pthreads pool helper support (default=yes)])])
if test x"$enable_pthreadpool" = xyes -a x"$samba_cv_HAVE_PTHREAD" != x"yes"; then
AC_MSG_ERROR([pthreadpool support cannot be enabled when pthread support was not found])
fi
-if test x"$enable_pthreadpool" = x"yes" -a x"$samba_cv_HAVE_PTHREAD" = x"yes"; then
+if test x"$enable_pthreadpool" != x"no" -a x"$samba_cv_HAVE_PTHREAD" = x"yes"; then
LIBS="$LIBS $PTHREAD_LDFLAGS"
CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
AC_SUBST(PTHREADPOOL_OBJ, "lib/pthreadpool/pthreadpool.o")
- if test x"$samba_cv_HAVE_AIO" = x"yes"; then
- default_shared_modules="$default_shared_modules vfs_aio_pthread"
- fi
+ default_shared_modules="$default_shared_modules vfs_aio_pthread"
else
AC_SUBST(PTHREADPOOL_OBJ, "lib/pthreadpool/pthreadpool_sync.o")
fi