summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in19
1 files changed, 17 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d8c6f53aef..fbab1143a2 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -742,7 +742,7 @@ AC_ARG_WITH(readline,
AC_CHECK_HEADERS(readline/history.h)
AC_CHECK_HEADERS(readline.h readline/readline.h,[
- for termlib in ncurses curses termcap terminfo termlib; do
+ for termlib in ncurses curses termcap terminfo termlib tinfo; do
AC_CHECK_LIB(${termlib}, tgetent, [TERMLIBS="-l${termlib}"; break])
done
AC_CHECK_LIB(readline, rl_callback_handler_install,
@@ -2082,6 +2082,21 @@ FOUND_KRB5=no
if test x"$with_ads_support" = x"yes"; then
#################################################
+ # check for krb5-config from recent MIT and Heimdal kerberos 5
+ AC_PATH_PROG(KRB5_CONFIG, krb5-config)
+ AC_MSG_CHECKING(for working krb5-config)
+ if test -x "$KRB5_CONFIG"; then
+ LIBS="$LIBS `$KRB5_CONFIG --libs`"
+ CFLAGS="$CFLAGS `$KRB5_CONFIG --cflags`"
+ CPPFLAGS="$CPPFLAGS `$KRB5_CONFIG --cflags`"
+ FOUND_KRB5=yes
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no. Fallback to previous krb5 detection strategy)
+ fi
+
+ if test x$FOUND_KRB5 = x"no"; then
+ #################################################
# check for location of Kerberos 5 install
AC_MSG_CHECKING(for kerberos 5 install path)
AC_ARG_WITH(krb5,
@@ -2101,7 +2116,7 @@ if test x"$with_ads_support" = x"yes"; then
esac ],
AC_MSG_RESULT(no)
)
-
+ fi
if test x$FOUND_KRB5 = x"no"; then
#################################################