summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4d8ef647c8..47ad2f97ea 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1424,6 +1424,25 @@ AC_ARG_WITH(utmp,
)
#################################################
+# check for MS Dfs support
+
+AC_MSG_CHECKING(whether to support MS Dfs)
+AC_ARG_WITH(msdfs,
+[ --with-msdfs Include MS Dfs support
+ --without-msdfs Don't include MS Dfs support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(MS_DFS)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+#################################################
# set private directory location
AC_ARG_WITH(privatedir,
[ --with-privatedir=DIR Where to put smbpasswd ($ac_default_prefix/private)],