summaryrefslogtreecommitdiff
path: root/source4/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'source4/configure.ac')
-rw-r--r--source4/configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/source4/configure.ac b/source4/configure.ac
index a841ab1c12..c99205a466 100644
--- a/source4/configure.ac
+++ b/source4/configure.ac
@@ -53,15 +53,22 @@ SMB_INCLUDED_LIB_PKGCONFIG(LIBTALLOC, talloc >= TALLOC_MIN_VERSION, [],
)
SMB_INCLUDED_LIB_PKGCONFIG(LIBTDB, tdb >= TDB_MIN_VERSION,
- [],
+ [
+ AC_MSG_CHECKING([for Python TDB bindings])
+ if $PYTHON -c "from tdb import open" 2>/dev/null; then
+ AC_MSG_RESULT(yes)
+ else
+ SMB_INCLUDE_MK(../lib/tdb/python.mk)
+ AC_MSG_RESULT(no)
+ fi
+ ],
[
m4_include(../lib/tdb/libtdb.m4)
SMB_INCLUDE_MK(../lib/tdb/config.mk)
+ SMB_INCLUDE_MK(../lib/tdb/python.mk)
]
)
-SMB_INCLUDE_MK(../lib/tdb/python.mk)
-
SMB_INCLUDED_LIB_PKGCONFIG(LIBTEVENT, tevent = TEVENT_REQUIRED_VERSION,
[],[m4_include(../lib/tevent/samba.m4)]
)