summaryrefslogtreecommitdiff
path: root/source4/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'source4/configure.ac')
-rw-r--r--source4/configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/source4/configure.ac b/source4/configure.ac
index be9f627d69..ac7998ba5f 100644
--- a/source4/configure.ac
+++ b/source4/configure.ac
@@ -50,14 +50,16 @@ m4_include(lib/appweb/config.m4)
m4_include(nsswitch/config.m4)
m4_include(libcli/config.m4)
-dnl disabled until we support external heimdal again
+USESHARED=$BLDSHARED
+
AC_ARG_ENABLE(dso,
-[ --enable-dso Enable building internal libraries as DSO's (experimental)],
+[ --enable-dso Enable using shared libraries internally (experimental)],
[ if test x$enable_dso != xno; then
- BLDSHARED=true
+ USESHARED=true
fi],
-[BLDSHARED=false])
+[USESHARED=false])
+AC_SUBST(USESHARED)
#################################################
# add *_CFLAGS only for the real build