summaryrefslogtreecommitdiff
path: root/source4/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'source4/configure.ac')
-rw-r--r--source4/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/source4/configure.ac b/source4/configure.ac
index bb326985f3..4305bf717d 100644
--- a/source4/configure.ac
+++ b/source4/configure.ac
@@ -43,6 +43,18 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBTDB, tdb >= 1.1.0,
]
)
+SMB_EXT_LIB_FROM_PKGCONFIG(LIBLDB, ldb >= 0.9.1,
+ [
+ SMB_INCLUDE_MK(lib/ldb/ldb_ildap/config.mk)
+ SMB_INCLUDE_MK(lib/ldb/tools/config.mk)
+ SMB_SUBSYSTEM(ldb_map, LIBLDB)
+ ],
+ [
+ m4_include(lib/ldb/libldb.m4)
+ SMB_INCLUDE_MK(lib/ldb/config.mk)
+ ]
+)
+
m4_include(lib/ldb/sqlite3.m4)
m4_include(lib/ldb/libldb.m4)
m4_include(lib/tls/config.m4)