summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/source4/configure.in b/source4/configure.in
index 5c23849ae6..eb1fd7de10 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -146,12 +146,15 @@ AC_SUBST(EXTRA_BIN_PROGS)
AC_SUBST(EXTRA_SBIN_PROGS)
AC_SUBST(EXTRA_ALL_TARGETS)
+debug=no
AC_ARG_ENABLE(debug,
[ --enable-debug Turn on compiler debugging information (default=no)],
[if eval "test x$enable_debug = xyes"; then
+ debug=yes
CFLAGS="${CFLAGS} -gstabs"
fi])
+developer=no
AC_ARG_ENABLE(developer, [ --enable-developer Turn on developer warnings and debugging (default=no)],
[if eval "test x$enable_developer = xyes"; then
developer=yes
@@ -164,6 +167,12 @@ AC_ARG_ENABLE(krb5developer, [ --enable-krb5developer Turn on developer warnin
CFLAGS="${CFLAGS} -gstabs -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -DDEBUG_PASSWORD -DDEVELOPER"
fi])
+experimental=no
+AC_ARG_ENABLE(experimental, [ --enable-experimental Turn on experimental features (default=no)],
+ [if eval "test x$enable_experimental = xyes"; then
+ experimental=yes
+ fi])
+
sinclude(build/m4/rewrite.m4)
dnl exclude these modules