summaryrefslogtreecommitdiff
path: root/source4/lib/tdb/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'source4/lib/tdb/configure.ac')
-rw-r--r--source4/lib/tdb/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/source4/lib/tdb/configure.ac b/source4/lib/tdb/configure.ac
index 3237d29fb0..5747107f38 100644
--- a/source4/lib/tdb/configure.ac
+++ b/source4/lib/tdb/configure.ac
@@ -12,4 +12,14 @@ AC_LD_SHLIBEXT
AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
m4_include(libtdb.m4)
+AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
+
+PYTHON_BUILD_TARGET="build-python"
+PYTHON_INSTALL_TARGET="install-python"
+AC_SUBST(PYTHON_BUILD_TARGET)
+AC_SUBST(PYTHON_INSTALL_TARGET)
+if test -z "$PYTHON_CONFIG"; then
+ PYTHON_BUILD_TARGET=""
+ PYTHON_INSTALL_TARGET=""
+fi
AC_OUTPUT(Makefile tdb.pc)