summaryrefslogtreecommitdiff
path: root/source4/pidl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'source4/pidl/Makefile.PL')
-rwxr-xr-xsource4/pidl/Makefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/source4/pidl/Makefile.PL b/source4/pidl/Makefile.PL
new file mode 100755
index 0000000000..ae862bfdb5
--- /dev/null
+++ b/source4/pidl/Makefile.PL
@@ -0,0 +1,16 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Parse::Pidl',
+ 'VERSION_FROM' => 'Parse/Pidl.pm',
+ 'EXE_FILES' => [ 'pidl' ],
+ 'PMLIBDIRS' => [ 'Parse' ],
+ 'C' => [],
+ 'test' => { 'TESTS' => 'tests/*.pl' }
+);
+
+sub MY::postamble {
+<<'EOT';
+Parse/Pidl/IDL.pm :: idl.yp
+ yapp -s -m 'Parse::Pidl::IDL' -o 'Parse/Pidl/IDL.pm' idl.yp
+EOT
+}