summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d4c3187..e5f34b3f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1551,10 +1551,19 @@ libsss_krb5_common_la_SOURCES = \
src/providers/krb5/krb5_auth.c \
src/providers/krb5/krb5_access.c \
src/providers/krb5/krb5_child_handler.c \
- src/providers/krb5/krb5_init_shared.c
+ src/providers/krb5/krb5_init_shared.c \
+ src/util/sss_krb5.c \
+ src/util/find_uid.c
+
libsss_krb5_common_la_LIBADD = \
- $(KEYUTILS_LIBS)
+ $(KEYUTILS_LIBS) \
+ $(SYSTEMD_LOGIN_LIBS) \
+ $(KRB5_LIBS) \
+ libsss_debug.la
+
libsss_krb5_common_la_LDFLAGS = \
+ $(SYSTEMD_LOGIN_CFLAGS) \
+ $(KRB5_CFLAGS) \
-avoid-version
libsss_ldap_la_SOURCES = \