summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-06 15:18:26 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-07 15:35:56 +0200
commit32da405cbd0ad3b9964c72d07d8fe921f815fb32 (patch)
tree1c29a12bdb766e5413263ae84c414abc988e562f /src/Makefile.am
parent03da3083dc111e005da4d57c499966983d3fa7c8 (diff)
downloadcmumble-32da405cbd0ad3b9964c72d07d8fe921f815fb32.tar.gz
cmumble-32da405cbd0ad3b9964c72d07d8fe921f815fb32.tar.bz2
cmumble-32da405cbd0ad3b9964c72d07d8fe921f815fb32.zip
Use AC_PATH_PROG for protoc-c
Also move PROTOC_C substution directly into src/protoc-c.sh.in instead of src/Makefile.am
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fe69d24..fb88fc6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,12 +15,11 @@ AM_CFLAGS = $(GCC_FLAGS)
BUILT_SOURCES = $(nodist_cmumble_SOURCES) $(nodist_noinst_HEADERS)
CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST = mumble.proto messages.txt gen_messages.sed protoc-c.sh
+EXTRA_DIST = mumble.proto messages.txt gen_messages.sed
messages.h: $(srcdir)/messages.txt $(srcdir)/gen_messages.sed
$(AM_V_GEN) LC_ALL=C $(SED) -f $(srcdir)/gen_messages.sed $< > $@
mumble.pb-c.c mumble.pb-c.h: $(srcdir)/mumble.proto
- $(AM_V_GEN) PROTOC_C=$(PROTOBUF_EXECUTABLE) \
- $(srcdir)/protoc-c.sh $< $@
+ $(AM_V_GEN) $(builddir)/protoc-c.sh $< $@