summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e109315..1dc6235 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,8 @@ AC_PROG_CC
AC_PROG_SED
AC_PATH_PROG([PROTOC_C], [protoc-c], [false])
-AC_CHECK_LIB(readline, readline)
+AC_CHECK_LIB([readline], [readline],
+ [], [AC_MSG_ERROR([libreadline not found])], [-lncurses])
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(PROTOBUF, [libprotobuf-c],[], [