summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 567b3f9..18979d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,12 +18,12 @@ AM_CFLAGS = $(GCC_CFLAGS)
BUILT_SOURCES = $(nodist_cmumble_SOURCES) $(nodist_noinst_HEADERS)
MAINTAINERCLEANFILES = mumble.pb-c.c mumble.pb-c.h
CLEANFILES = message_list.h
-EXTRA_DIST = mumble.proto messages.txt gen_message_list.sed
+EXTRA_DIST = mumble.proto gen_message_list.sed
# Ship files generated by protoc-c in releases,
# so that protoc-c (which pulls in the c++ protobuf) is not needed.
EXTRA_DIST += mumble.pb-c.c mumble.pb-c.h
-message_list.h: $(srcdir)/messages.txt $(srcdir)/gen_message_list.sed
+message_list.h: $(srcdir)/mumble.proto $(srcdir)/gen_message_list.sed
$(AM_V_GEN) LC_ALL= LC_COLLATE=C $(SED) -f $(srcdir)/gen_message_list.sed $< > $@
mumble.pb-c.c mumble.pb-c.h: $(srcdir)/mumble.proto