summaryrefslogtreecommitdiff
path: root/Source/DirectFB/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Source/DirectFB/docs/Makefile.am')
-rwxr-xr-xSource/DirectFB/docs/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Source/DirectFB/docs/Makefile.am b/Source/DirectFB/docs/Makefile.am
new file mode 100755
index 0000000..df6c89b
--- /dev/null
+++ b/Source/DirectFB/docs/Makefile.am
@@ -0,0 +1,40 @@
+## Makefile.am for DirectFB/docs
+
+SUBDIRS = html
+
+if BUILD_DIRECTFB_CSOURCE
+csource_mans = directfb-csource.1
+endif
+
+man_MANS = \
+ $(csource_mans) \
+ dfbg.1 \
+ directfbrc.5
+
+HTMLMANS = $(patsubst %,%.html,$(man_MANS))
+
+
+if HAVE_MAN2HTML
+
+all-local: $(HTMLMANS)
+
+clean-local:
+ rm -f $(HTMLMANS)
+
+%.html: %
+ $(MAN2HTML) $* > $@
+
+else
+
+all-local:
+
+clean-local:
+
+endif
+
+
+EXTRA_DIST = \
+ README.screenshots \
+ dfbg.1.in \
+ directfbrc.5.in \
+ directfb-csource.1.in