summaryrefslogtreecommitdiff
path: root/docs/docbook/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2003-03-17 10:26:44 +0000
committerTim Potter <tpot@samba.org>2003-03-17 10:26:44 +0000
commit63c1aa25cfbc96abf67bb4f5c99291d05bffb9bb (patch)
treea5c1cefd5249c338b23e6ac923c429730af3ff47 /docs/docbook/configure.in
parent0273df0bf75f135a781ca6b58cc4c7e3247e5aef (diff)
downloadsamba-63c1aa25cfbc96abf67bb4f5c99291d05bffb9bb.tar.gz
samba-63c1aa25cfbc96abf67bb4f5c99291d05bffb9bb.tar.bz2
samba-63c1aa25cfbc96abf67bb4f5c99291d05bffb9bb.zip
Call AC_MSG_ERROR if jw, perl or htmldoc is not installed rather than
generate a bodgy Makefile. (This used to be commit 2842e0925debe8bfabfdf011913cf5e13e824c10)
Diffstat (limited to 'docs/docbook/configure.in')
-rw-r--r--docs/docbook/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/docs/docbook/configure.in b/docs/docbook/configure.in
index 3a9ed51d16..57482d134e 100644
--- a/docs/docbook/configure.in
+++ b/docs/docbook/configure.in
@@ -1,8 +1,18 @@
AC_INIT(global.ent)
+# Jade wrapper
AC_PATH_PROG(JW, jw)
+if test "x$JW" = x; then
+ AC_MSG_ERROR("jw is required")
+fi
AC_PATH_PROG(PERL, perl)
+if test "x$PERL" = x; then
+ AC_MSG_ERROR("perl is required")
+fi
AC_PATH_PROG(HTMLDOC, htmldoc)
+if test "x$HTMLDOC" = x; then
+ AC_MSG_ERROR("htmldoc is required")
+fi
DOC_BUILD_DATE=`date '+%d-%m-%Y'`
AC_SUBST(DOC_BUILD_DATE)