summaryrefslogtreecommitdiff
path: root/examples/VFS/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2006-11-23 06:44:05 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:16:02 -0500
commit55170cb6a7735b28e371e52cf16af2677425adb4 (patch)
treef67365462b5adc0d00540b45afd74b6b8e8d19fc /examples/VFS/configure.in
parente2166a9feee8f05a6a6ede7d9e4527a3d93774b2 (diff)
downloadsamba-55170cb6a7735b28e371e52cf16af2677425adb4.tar.gz
samba-55170cb6a7735b28e371e52cf16af2677425adb4.tar.bz2
samba-55170cb6a7735b28e371e52cf16af2677425adb4.zip
r19852: Fix the build for the VFS examples. Fixes bugzilla #3931.
(This used to be commit fa69031d00f914aa8d642a2731db8c81f74bc8d9)
Diffstat (limited to 'examples/VFS/configure.in')
-rw-r--r--examples/VFS/configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/examples/VFS/configure.in b/examples/VFS/configure.in
index 515d43f009..e96101b091 100644
--- a/examples/VFS/configure.in
+++ b/examples/VFS/configure.in
@@ -5,14 +5,14 @@ dnl We must use autotools 2.53 or above
AC_PREREQ(2.53)
AC_INIT(Makefile.in)
-#dnl Uncomment this if you want to use your own define's too
-#AC_CONFIG_HEADER(module_config.h)
+AC_CONFIG_HEADER(module_config.h)
#dnl To make sure that didn't get #define PACKAGE_* in modules_config.h
#echo "" > confdefs.h
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
+AC_CANONICAL_HOST
#################################################
# Directory handling stuff to support both the
@@ -309,6 +309,11 @@ if test "$enable_shared" = "yes"; then
BLDSHARED="false"
LDSHFLAGS=""
;;
+ *darwin*)
+ BLDSHARED="true"
+ LDSHFLAGS="-bundle -flat_namespace -undefined suppress"
+ SHLIBEXT="dylib"
+ ;;
*)
;;
esac
@@ -328,7 +333,7 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
ac_cv_shlib_works=no
# try building a trivial shared library
if test "$PICSUFFIX" = "po"; then
- $CC $CPPFLAGS $CFLAGS $PICFLAGS -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
+ $CC $CPPFLAGS $CFLAGS $PICFLAGS -c -o shlib.po ${srcdir-.}/../../source/tests/shlib.c &&
$CC $CPPFLAGS $CFLAGS `eval echo $LDSHFLAGS` -o "shlib.$SHLIBEXT" shlib.po &&
ac_cv_shlib_works=yes
else