summaryrefslogtreecommitdiff
path: root/packaging/debian/rules
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2004-05-14 12:05:48 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:53:45 -0500
commita07f42b4ffee81e62ea7f586241c97fd5e55a819 (patch)
treebe6b28b91ae2b142521622e3beb77cbf7ff22407 /packaging/debian/rules
parentc731e565da542ae5d98ae56ffbb02e475e10daa7 (diff)
downloadsamba-a07f42b4ffee81e62ea7f586241c97fd5e55a819.tar.gz
samba-a07f42b4ffee81e62ea7f586241c97fd5e55a819.tar.bz2
samba-a07f42b4ffee81e62ea7f586241c97fd5e55a819.zip
r727: Start working on debian package for samba4
(This used to be commit 3fb009b719451ef3253051d06b0bdbca87d4557d)
Diffstat (limited to 'packaging/debian/rules')
-rwxr-xr-xpackaging/debian/rules68
1 files changed, 68 insertions, 0 deletions
diff --git a/packaging/debian/rules b/packaging/debian/rules
new file mode 100755
index 0000000000..5de994450d
--- /dev/null
+++ b/packaging/debian/rules
@@ -0,0 +1,68 @@
+#!/usr/bin/make -f
+# By Jelmer Vernooij
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=samba4
+
+configure:
+ $(checkdir)
+ cd source && ./autogen.sh
+ cd source && ./configure --with-fhs \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-static \
+ --sysconfdir=/etc \
+ --libdir=/etc/samba4 \
+ --with-privatedir=/etc/samba4 \
+ --with-piddir=/var/run/samba4 \
+ --localstatedir=/var \
+ --with-pam \
+ --with-syslog \
+ --with-readline \
+ --with-ldap
+
+ touch configure
+
+build: configure
+ $(checkdir)
+ cd source && $(MAKE) proto all
+ touch build
+
+clean:
+ $(checkdir)
+ rm -f build
+ -cd source && $(MAKE) clean
+ rm -f `find . -name "*~"`
+ rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
+ rm -f debian/*substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ rm -rf debian/tmp `find debian/* -type d ! -name CVS`
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ cd source && $(MAKE) install DESTDIR=`pwd`/../debian/tmp
+ debstd
+ dpkg-gencontrol -isp -psamba4
+ chown -R root:root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot