summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-03 02:25:28 +0000
committerJeremy Allison <jra@samba.org>1998-11-03 02:25:28 +0000
commit01e04614c7c466fdbdc398c782acaa931965f925 (patch)
treea1fcea4972a969633b057a6f99a611d379f1fe76 /source3/configure.in
parent5900f6c85bfdf43712f51528b9d14b14338c8a0d (diff)
downloadsamba-01e04614c7c466fdbdc398c782acaa931965f925.tar.gz
samba-01e04614c7c466fdbdc398c782acaa931965f925.tar.bz2
samba-01e04614c7c466fdbdc398c782acaa931965f925.zip
Makefile.in configure configure.in include/proto.h smbd/noquotas.c smbd/quotas.c:
Added quotas patch for autoconf from Dejan Ilic <svedja@lysator.liu.se>. printing/printing.c: Filenames with spaces patch from Allan Bjorklund <allan@umich.edu> utils/nmblookup.c: Fix usage() function. smbd/reply.c: Split out the security=server and security=domain checks into check_server_security() and check_domain_security() to aid the writing of the 'hack' appliance mode invented by John Schimmel. Jeremy. (This used to be commit f09ab9b52251087a58af92ec753537ca34a970fc)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cb26606a7c..a52b02fe87 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -762,6 +762,26 @@ AC_ARG_WITH(netatalk,
AC_MSG_RESULT(no)
)
+#################################################
+# check for experimental disk-quotas support
+QUOTAOBJS=noquotas.o
+
+AC_MSG_CHECKING(whether to support disk-quotas)
+AC_ARG_WITH(quotas,
+[ --with-quotas Include experimental disk-quota support
+ --without-quotas Don't include experimental disk-quota support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ QUOTAOBJS=quotas.o
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+AC_SUBST(QUOTAOBJS)
#################################################
# these tests are taken from the GNU fileutils package