summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2008-06-17 22:45:29 +1000
committerAndrew Bartlett <abartlet@samba.org>2008-06-17 22:45:29 +1000
commit086de4ddb522dd6d1ce927da2e2c14ed0ffca10f (patch)
treeef044b0cb38ee9b477cb79bb2373559e53b537c4 /source3/configure.in
parentf21058d61ee6f0661f58c998af84419ee642cbf5 (diff)
downloadsamba-086de4ddb522dd6d1ce927da2e2c14ed0ffca10f.tar.gz
samba-086de4ddb522dd6d1ce927da2e2c14ed0ffca10f.tar.bz2
samba-086de4ddb522dd6d1ce927da2e2c14ed0ffca10f.zip
Without stdlib.h we don't get a prototype for free().
This test fails if GCC emits any warnings (presumably to detect the function propertly), but unless we include this message then free() fail. Why we need to call free in a configure test is probably something to blame on valgrind... Andrew Bartlett (This used to be commit d013f6fadc3e80fabb4a1784207dabc84f9b7dc2)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7ac13398c9..e25c213d03 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3779,6 +3779,7 @@ if test x"$with_ads_support" != x"no"; then
AC_CACHE_CHECK([for krb5_error_code krb5_enctype_to_string(krb5_context context, krb5_enctype enctype, char **str)],
smb_krb5_cv_enctype_to_string_takes_krb5_context_arg,[
AC_TRY_RUN_STRICT([
+ #include <stdlib.h>
#include <krb5.h>
int main(void) {
krb5_context context = NULL;