summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-11-13 07:04:00 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-11-13 07:04:00 +0000
commit098c08ccabe164492d6a91372608f5feb0de0d47 (patch)
tree7421c6961dd6f588785f0877c19a3277e5bdf4ac /source3/configure.in
parentce35c5d0fa62b3940cb76ed6d65712f8e2a15de4 (diff)
downloadsamba-098c08ccabe164492d6a91372608f5feb0de0d47.tar.gz
samba-098c08ccabe164492d6a91372608f5feb0de0d47.tar.bz2
samba-098c08ccabe164492d6a91372608f5feb0de0d47.zip
Merge from HEAD
- make configure check for the location of Heimdal KRB5 on suse systems - fix libsmbclient for new global_myname() (This used to be commit 111b0405cf8c95da5c927f31e5db7fd51c590b1f)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 16e9af4b47..3c5f74a67e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1989,6 +1989,20 @@ if test x"$with_ads_support" = x"yes"; then
if test x$FOUND_KRB5 = x"no"; then
#################################################
+# see if this box has the SuSE location for the heimdal kerberos implementation
+AC_MSG_CHECKING(for /usr/include/heimdal)
+if test -d /usr/include/heimdal; then
+ CFLAGS="$CFLAGS -I/usr/heimdal/include"
+ CPPFLAGS="$CPPFLAGS -I/usr/heimdal/include"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+fi
+
+
+if test x$FOUND_KRB5 = x"no"; then
+#################################################
# see if this box has the RedHat location for kerberos
AC_MSG_CHECKING(for /usr/kerberos)
if test -d /usr/kerberos; then