summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2004-01-14 01:14:22 +0000
committerAndrew Bartlett <abartlet@samba.org>2004-01-14 01:14:22 +0000
commit0c0dfe4da56f52164da6e6633d2f8815d9d170fd (patch)
tree7c8b203673163f7c50b1e2ac3b99c936029aeb44 /source3/configure.in
parentb085f0f08eb66fd5741b6cb221fbfa67504514f2 (diff)
downloadsamba-0c0dfe4da56f52164da6e6633d2f8815d9d170fd.tar.gz
samba-0c0dfe4da56f52164da6e6633d2f8815d9d170fd.tar.bz2
samba-0c0dfe4da56f52164da6e6633d2f8815d9d170fd.zip
Finish adding cracklib support - this adds the configure test to enable
it, on machines that actually have a working cracklib, for which we have the correct path to the dictionary. Andrew Bartlett (This used to be commit 17518018c0264d2a8e4afbc712a22ef4a1a00003)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in58
1 files changed, 58 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7a844c337d..375eed06ab 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2961,6 +2961,64 @@ if test x"$samba_cv_HAVE_TRUNCATED_SALT" = x"yes"; then
fi
fi
+
+dictpath="/usr/lib/cracklib_dict"
+
+###############################################
+# test for where we get FaciestCheck from
+AC_MSG_CHECKING(where to use cracklib from (default=$dictpath))
+AC_ARG_WITH(cracklib,
+[ --with-cracklib[=DIR] Look for cracklib dictionary in this location ],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(${dictpath})
+ ;;
+ no)
+ AC_MSG_RESULT(no)
+ dictpath=""
+ ;;
+ *)
+ dictpath="$withval"
+ AC_MSG_RESULT(${dictpath})
+ ;;
+ esac ],
+ dictpath=""
+ AC_MSG_RESULT(no)
+)
+
+if test x$dictpath != x""; then
+ AC_SEARCH_LIBS(FascistCheck, [crack],
+ [test "$ac_cv_search_crack" = "none required" || samba_cv_found_crack="yes"
+ AC_DEFINE(HAVE_CRACK,1,[Whether the system has the FaciestCheck function from cracklib])])
+
+ crack_saved_libs=$LIBS;
+
+ if test x$samba_cv_found_crack=x"yes"; then
+ AC_SEARCH_LIBS(CRACKLIB_DICTPATH, [crypt],
+ AC_DEFINE(HAVE_CRACKLIB_DICTPATH, 1, [Whether we have given a CRACKLIB_DICTPATH in our headers])
+ )
+
+ AC_DEFINE_UNQUOTED(SAMBA_CRACKLIB_DICTPATH, "$dictpath", [Where the cracklib dictionay is])
+ AC_MSG_CHECKING(Whether we have a working cracklib)
+ AC_TRY_RUN([
+ #include "${srcdir-.}/tests/crack.c"],
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_WORKING_CRACKLIB,1,[Whether we have a working cracklib])
+ AUTH_LIBS="-lcrack $AUTH_LIBS",
+
+ AC_MSG_RESULT(no)
+ AC_MSG_WARN(cracklib exists - but does not function correctly),
+
+ AC_MSG_RESULT(no)
+ AC_MSG_WARN(cannot test-run when cross-compiling)
+ )
+ else
+ AC_MSG_CHECKING(Whether we have cracklib)
+ AC_MSG_RESULT(no)
+ fi
+ LIBS=$crack_saved_libs
+fi
+
########################################################################################
##
## TESTS FOR SAM BACKENDS. KEEP THESE GROUPED TOGETHER