summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Prouty <tprouty@samba.org>2009-01-27 16:13:35 -0800
committerTim Prouty <tprouty@samba.org>2009-02-09 23:47:45 -0800
commit16d2c2fa58c57539a9b540eb93825806caaea0b5 (patch)
treef9e36ba11388ece127fa82c7eb96bfbc6a853902 /source3/configure.in
parent32d68b8ec3aee7853c7547296e829277515813d1 (diff)
downloadsamba-16d2c2fa58c57539a9b540eb93825806caaea0b5.tar.gz
samba-16d2c2fa58c57539a9b540eb93825806caaea0b5.tar.bz2
samba-16d2c2fa58c57539a9b540eb93825806caaea0b5.zip
s3 OneFS: Add kernel oplocks implementation
A few functions in oplocks_onefs.c need to be accessed from the onefs vfs module. It would be ideal if oplocks were implemented at the vfs layer, but since they aren't yet, a new header is added to source3/include to make these functions available to the onefs vfs module. oplocks_onefs.o doesn't need to be linked into the onefs vfs module explicitly, since it is already linked into smbd by default.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b81e768073..10ce6f6e5e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1099,6 +1099,8 @@ if test x"$samba_cv_HAVE_ONEFS" = x"yes"; then
AC_DEFINE(HAVE_ONEFS,1,[Whether building on Isilon OneFS])
default_shared_modules="$default_shared_modules vfs_onefs perfcount_onefs"
ONEFS_LIBS="-lisi_acl"
+ # Need to also add general libs for oplocks support
+ save_LIBS="$save_LIBS -lisi_ecs -lisi_event -lisi_util -ldevstat"
fi
AC_SUBST(ONEFS_LIBS)
LIBS="$save_LIBS"