summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-09-18 17:50:18 +0000
committerJeremy Allison <jra@samba.org>1998-09-18 17:50:18 +0000
commit184db9266efcbcea13169f99002b32208dc2ec9b (patch)
treeaa12011b6b4d3600130ec6032213f84aa4ca072e /source3/configure.in
parent717f538e2efdce231f6b9255be998cc4495337df (diff)
downloadsamba-184db9266efcbcea13169f99002b32208dc2ec9b.tar.gz
samba-184db9266efcbcea13169f99002b32208dc2ec9b.tar.bz2
samba-184db9266efcbcea13169f99002b32208dc2ec9b.zip
configure configure.in include/config.h.in include/includes.h
Fixed bugs in readline autoconf. param/loadparm.c smbd/open.c smbd/oplock.c: Started on kernel oplock code - checking forced by above issue. Should not be used currently. Jeremy. (This used to be commit f939efac9e6c45331b17e3d3aa6bc2235e886c1a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 0006380416..9fe21b93bb 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -36,7 +36,8 @@ AC_CHECK_HEADERS(sys/filio.h string.h strings.h stdlib.h sys/socket.h)
AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h)
AC_CHECK_HEADERS(sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h sys/sockio.h)
AC_CHECK_HEADERS(shadow.h netinet/tcp.h sys/security.h security/pam_appl.h)
-AC_CHECK_HEADERS(stropts.h poll.h )
+AC_CHECK_HEADERS(stropts.h poll.h readline.h history.h readline/readline.h)
+AC_CHECK_HEADERS(readline/history.h)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
@@ -124,6 +125,14 @@ if test "$ac_cv_lib_pam_pam_authenticate" = "yes"; then
fi])
fi
+###############################################
+# test for where we get readline() from
+if test "$ac_cv_header_readline_h" = "yes" ||
+ test "$ac_cv_header_readline_readline_h" = "yes"; then
+ AC_CHECK_LIB(readline,readline)
+ AC_DEFINE(HAVE_LIBREADLINE)
+fi
+
# The following test taken from the cvs sources
# If we can't find connect, try looking in -lsocket, -lnsl, and -linet.
# The Irix 5 libc.so has connect and gethostbyname, but Irix 5 also has