summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vlendec@samba.org>2003-09-07 16:36:13 +0000
committerVolker Lendecke <vlendec@samba.org>2003-09-07 16:36:13 +0000
commit1c38391c704756c31c1d8d7f84f9ac6ffcaeda34 (patch)
tree441c2ae1a1649d71db20ef907c779f5c32a13e63 /source3/configure.in
parentc4b69a9ca1e7881aa6d37056ed12d8ccd18b0a41 (diff)
downloadsamba-1c38391c704756c31c1d8d7f84f9ac6ffcaeda34.tar.gz
samba-1c38391c704756c31c1d8d7f84f9ac6ffcaeda34.tar.bz2
samba-1c38391c704756c31c1d8d7f84f9ac6ffcaeda34.zip
Nobody complained on the team-list, so commit it ...
This implements some kind of improved AFS support for Samba on Linux with OpenAFS 1.2.10. ./configure --with-fake-kaserver assumes that you have OpenAFS on your machine. To use this, you have to put the AFS server's KeyFile into secrets.tdb with 'net afskey'. If this is done, on each tree connect smbd creates a Kerberos V4 ticket suitable for use by the AFS client and gives it to the kernel via the AFS syscall. This is meant to be very light-weight, so I did not link in a whole lot of libraries to be more platform-independent using the ka_SetToken function call. Volker (This used to be commit 5775690ee8e17d3e98355b5147e4aed47e8dc213)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 92fdfc10cd..27eeaaeab1 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2181,6 +2181,22 @@ AC_ARG_WITH(afs,
AC_MSG_RESULT(no)
)
+####################################################
+# check for Linux-specific AFS fake-kaserver support
+AC_MSG_CHECKING(whether to use AFS fake-kaserver)
+AC_ARG_WITH(fake-kaserver,
+[ --with-fake-kaserver Include AFS fake-kaserver support (default=no) ],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_FAKE_KASERVER,1,[Whether to include AFS fake-kaserver support])
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
#################################################
# check for the DFS clear-text auth system