summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-02-22 03:29:13 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-02-22 03:29:13 +0000
commit1d3560bd4c49614a8c74488d76ab94d2215438ef (patch)
tree412ba2cbaa28f1d75544c9a6c5b0623fd1e21bc2 /source3/configure.in
parent488b01f79a1023b81739add0b78da35ad4168020 (diff)
downloadsamba-1d3560bd4c49614a8c74488d76ab94d2215438ef.tar.gz
samba-1d3560bd4c49614a8c74488d76ab94d2215438ef.tar.bz2
samba-1d3560bd4c49614a8c74488d76ab94d2215438ef.zip
Get rid of the unused WL variable from the previous patch. I think these were
meant to be DYNEXP, but I'll confirm that with the original contributor. Thanks to vance for spotting this! Andrew Bartlett (This used to be commit cf9cae48e66a14530b5cc5452a4767479de7ef82)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in37
1 files changed, 17 insertions, 20 deletions
diff --git a/source3/configure.in b/source3/configure.in
index acd043294d..25e17328b7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -710,12 +710,12 @@ case "$host_os" in
*linux*) AC_DEFINE(LINUX)
BLDSHARED="true"
LDSHFLAGS="-shared"
- DYNEXP="-Wl,--export-dynamic"
+ DYNEXP="-Wl,--export-dynamic"
PICFLAG="-fPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
*solaris*)
- AC_DEFINE(SUNOS5)
+ AC_DEFINE(SUNOS5)
BLDSHARED="true"
LDSHFLAGS="-h \$@ -G"
if test "${ac_cv_prog_CC}" = "gcc"; then
@@ -728,7 +728,6 @@ case "$host_os" in
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
*sunos*) AC_DEFINE(SUNOS4)
-# WL="-Qoption ld "
BLDSHARED="true"
LDSHFLAGS="-Wl,-h,\$@ -G"
PICFLAG="-KPIC" # Is this correct for SunOS
@@ -768,20 +767,19 @@ case "$host_os" in
LDSHFLAGS="-b -z +h \$@"
PICFLAG="+z"
fi
- DYNEXP="-Wl,-E"
+ DYNEXP="-Wl,-E"
AC_DEFINE(STAT_ST_BLOCKSIZE,8192)
;;
*qnx*) AC_DEFINE(QNX);;
*osf*) AC_DEFINE(OSF1)
- WL="-Wl,"
BLDSHARED="true"
LDSHFLAGS="-Wl,-soname,\$@ -shared"
PICFLAG="-fPIC"
;;
*sco*)
- DYNEXP="-Wl,-Bexport"
- AC_DEFINE(SCO)
- ;;
+ DYNEXP="-Wl,-Bexport"
+ AC_DEFINE(SCO)
+ ;;
*unixware*) AC_DEFINE(UNIXWARE)
BLDSHARED="true"
LDSHFLAGS="-Wl,-soname,\$@ -shared"
@@ -791,26 +789,25 @@ case "$host_os" in
*dgux*) AC_CHECK_PROG( ROFF, groff, [groff -etpsR -Tascii -man]);;
*sysv4*)
case "$host" in
- *-univel-*) if [ test "$GCC" != yes ]; then
- AC_DEFINE(HAVE_MEMSET)
- fi
- LDSHFLAGS="-G"
- DYNEXP="-Bexport"
+ *-univel-*)
+ if [ test "$GCC" != yes ]; then
+ AC_DEFINE(HAVE_MEMSET)
+ fi
+ LDSHFLAGS="-G"
+ DYNEXP="-Bexport"
;;
- *mips-sni-sysv4*)
- AC_DEFINE(RELIANTUNIX)
- WL="-LD"
- ;;
+ *mips-sni-sysv4*)
+ AC_DEFINE(RELIANTUNIX)
+ ;;
esac
- ;;
+ ;;
*sysv5*)
- WL="-Wl,"
if [ test "$GCC" != yes ]; then
AC_DEFINE(HAVE_MEMSET)
fi
LDSHFLAGS="-G"
- ;;
+ ;;
esac
AC_SUBST(DYNEXP)
AC_MSG_RESULT($BLDSHARED)