summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2011-12-25 11:00:11 +0100
committerVolker Lendecke <vl@samba.org>2011-12-25 13:31:58 +0100
commit1fbc8c2186642564a19205b2d07b3d7190cfdadd (patch)
tree8351007dc21d6dc4c02b2f5f0329d3e4bbe676dc /source3/configure.in
parent1eefd6bafba689e807e208149ee39b0f773c1ff8 (diff)
downloadsamba-1fbc8c2186642564a19205b2d07b3d7190cfdadd.tar.gz
samba-1fbc8c2186642564a19205b2d07b3d7190cfdadd.tar.bz2
samba-1fbc8c2186642564a19205b2d07b3d7190cfdadd.zip
s3: Fix linking on Lion
We are using CoreFoundation functions in charset_macosx.c. We need to link against that.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cbea99d18c..6f4300cc48 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -768,6 +768,14 @@ CPPFLAGS="-Iinclude $CPPFLAGS"
AC_CHECK_HEADERS([CoreFoundation/CFStringEncodingConverter.h], [], [AC_CHECK_HEADERS([CFStringEncodingConverter.h])])
CPPFLAGS="$old_CPPFLAGS"
+# To link lib/util/charset/charset_macosxfs.c, we need to tell the linker
+# about CoreFoundation
+case "$host_os" in
+ *darwin11*)
+ LDFLAGS="$LDFLAGS -framework CoreFoundation"
+ ;;
+esac
+
# In valgrind 1.0.x, it's just valgrind.h. In 1.9.x+ there's a
# subdirectory of headers.
AC_CHECK_HEADERS(valgrind.h valgrind/valgrind.h valgrind/memcheck.h)