summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2008-08-18 13:49:59 -0400
committerJeff Layton <jlayton@redhat.com>2008-08-21 19:41:14 -0400
commit2c96b1fd5b932b7753a300ae426d25d459e65a6d (patch)
tree6cc8ce6cab3926e797a9c9962d4075cca99f870d /source3/configure.in
parenta835c28bb7e37d4968646a4727f23b1344137cc4 (diff)
downloadsamba-2c96b1fd5b932b7753a300ae426d25d459e65a6d.tar.gz
samba-2c96b1fd5b932b7753a300ae426d25d459e65a6d.tar.bz2
samba-2c96b1fd5b932b7753a300ae426d25d459e65a6d.zip
cifs.upcall: enable building by default on linux
When building on linux, default to building cifs.upcall. Throw a warning if ADS support is disabled or keyutils isn't installed. Signed-off-by: Jeff Layton <jlayton@redhat.com> (This used to be commit d8018d15f013b8d7be8618b75dac5112711193b7)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 2f99e7cd31..5508d9b01d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -4048,7 +4048,7 @@ INSTALL_CIFSUPCALL=""
UNINSTALL_CIFSUPCALL=""
AC_MSG_CHECKING(whether to build cifs.upcall)
AC_ARG_WITH(cifsupcall,
-[AS_HELP_STRING([--with-cifsupcall], [Include cifs.upcall (Linux only) support (default=no)])],
+[AS_HELP_STRING([--with-cifsupcall], [Include cifs.upcall (Linux only) support (default=yes)])],
[ case "$withval" in
no)
AC_MSG_RESULT(no)
@@ -4074,9 +4074,24 @@ AC_ARG_WITH(cifsupcall,
esac
;;
esac ],
-[
- AC_MSG_RESULT(no)
- ]
+[ case "$host_os" in
+ *linux*)
+ if test x"$use_ads" != x"yes"; then
+ AC_MSG_WARN(ADS support should be enabled for building cifs.upcall)
+ elif test x"$HAVE_KEYUTILS_H" != "x1"; then
+ AC_MSG_WARN(keyutils package is required for cifs.upcall)
+ else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_CIFSUPCALL,1,[whether to build cifs.upcall])
+ CIFSUPCALL_PROGS="bin/cifs.upcall"
+ INSTALL_CIFSUPCALL="installcifsupcall"
+ UNINSTALL_CIFSUPCALL="uninstallcifsupcall"
+ fi
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ]
)