summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2000-03-29 23:03:48 +0000
committerJeremy Allison <jra@samba.org>2000-03-29 23:03:48 +0000
commit332013e09efadabcf31c01852690960bf614abd7 (patch)
tree59e39e6a72d4f14574f511dd9a4f6db8843ff8c8 /source3/configure.in
parent0d9d264625e482f55b2c5b76d7aa7d989529dd07 (diff)
downloadsamba-332013e09efadabcf31c01852690960bf614abd7.tar.gz
samba-332013e09efadabcf31c01852690960bf614abd7.tar.bz2
samba-332013e09efadabcf31c01852690960bf614abd7.zip
Added check for LL suffix to long long ints needed by AIX 4.3.x compiler
to allow successful build. Jeremy. (This used to be commit 567713a07c089ab3ebb4c9b96087777de154b601)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 61af9f76ec..731b3b1233 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -548,6 +548,18 @@ if test x"$samba_cv_have_longlong" = x"yes"; then
AC_DEFINE(HAVE_LONGLONG)
fi
+#
+# Check if the compiler supports the LL prefix on long long integers.
+# AIX needs this.
+
+AC_CACHE_CHECK([for LL suffix on long long integers],samba_cv_compiler_supports_ll, [
+ AC_TRY_COMPILE([#include <stdio.h>],[long long i = 0x8000000000LL],
+ samba_cv_compiler_supports_ll=yes,samba_cv_compiler_supports_ll=no)])
+if test x"$samba_cv_compiler_supports_ll" = x"yes"; then
+ AC_DEFINE(COMPILER_SUPPORTS_LL)
+fi
+
+
AC_CACHE_CHECK([for 64 bit off_t],samba_cv_SIZEOF_OFF_T,[
AC_TRY_RUN([#include <stdio.h>
#include <sys/stat.h>