summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2007-10-03 19:12:39 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:31:08 -0500
commit334b288831c1730cb88fb431f684b9062e139efd (patch)
tree9ca090d479eb5d527fb1a396740a0f91ce73fc72 /source3/configure.in
parent5d552214e69acbf9863624f4eed6ae57b7bf1f14 (diff)
downloadsamba-334b288831c1730cb88fb431f684b9062e139efd.tar.gz
samba-334b288831c1730cb88fb431f684b9062e139efd.tar.bz2
samba-334b288831c1730cb88fb431f684b9062e139efd.zip
r25487: Try fix the build - fix socklen_t and sa_family_t.
Jeremy. (This used to be commit 2cab82563409eca79ac5f518a3dcb8cdbdcded7e)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in45
1 files changed, 43 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c8cdf0a018..2eb06bdcac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1082,7 +1082,6 @@ AC_CHECK_TYPE(loff_t,off_t)
AC_CHECK_TYPE(offset_t,loff_t)
AC_CHECK_TYPE(ssize_t, int)
AC_CHECK_TYPE(wchar_t, unsigned short)
-AC_CHECK_TYPE(socklen_t, int)
AC_CHECK_TYPE(comparison_fn_t,
[AC_DEFINE(HAVE_COMPARISON_FN_T, 1,[Whether or not we have comparison_fn_t])])
@@ -2502,6 +2501,16 @@ if test x"$samba_cv_HAVE_UT_UT_EXIT" = x"yes"; then
AC_DEFINE(HAVE_UT_UT_EXIT,1,[Whether the utmp struct has a property ut_exit])
fi
+dnl Look for the IPv6 varient by preference. Many systems have both.
+AC_CACHE_CHECK([for ut_addr_v6 in utmp],samba_cv_HAVE_UT_UT_ADDR_V6,[
+AC_TRY_COMPILE([#include <sys/types.h>
+#include <utmp.h>],
+[struct utmp ut; ut.ut_addr_v6[0] = 0;],
+samba_cv_HAVE_UT_UT_ADDR_V6=yes,samba_cv_HAVE_UT_UT_ADDR_V6=no,samba_cv_HAVE_UT_UT_ADDR_V6=cross)])
+if test x"$samba_cv_HAVE_UT_UT_ADDR_V6" = x"yes"; then
+ AC_DEFINE(HAVE_UT_UT_ADDR_V6,1,[Whether the utmp struct has a property ut_addr_v6])
+fi
+
AC_CACHE_CHECK([for ut_addr in utmp],samba_cv_HAVE_UT_UT_ADDR,[
AC_TRY_COMPILE([#include <sys/types.h>
#include <utmp.h>],
@@ -3039,11 +3048,29 @@ SMB_CHECK_SYSCONF(_SC_NPROCESSORS_ONLN)
SMB_CHECK_SYSCONF(_SC_PAGESIZE)
AC_CHECK_FUNCS(getpagesize)
+dnl test for socklen_t
+AC_CACHE_CHECK([for socklen_t],samba_cv_HAVE_SA_FAMILY_T,[
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <unistd.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+],
+[
+socklen_t foo;
+],
+samba_cv_HAVE_SOCKLEN_T=yes,samba_cv_HAVE_SOCKLEN_T=no)])
+if test x"$samba_cv_HAVE_SOCKLEN_T" = x"yes"; then
+ AC_DEFINE(HAVE_SOCKLEN_T,1,[Whether the system has socklen_t])
+fi
+
dnl test for sa_family_t
AC_CACHE_CHECK([for sa_family_t],samba_cv_HAVE_SA_FAMILY_T,[
AC_TRY_COMPILE([
-#include <sys/socket.h>
#include <sys/types.h>
+#include <unistd.h>
+#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
],
@@ -3158,6 +3185,20 @@ if test x"$samba_cv_HAVE_IPV6" = x"yes"; then
AC_DEFINE(HAVE_IPV6,1,[Whether the system has IPv6 support])
fi
+dnl test for struct sockaddr_storage
+AC_CACHE_CHECK([for ipv6 support],samba_cv_HAVE_SOCKADDR_STORAGE,[
+AC_TRY_COMPILE([
+#include <sys/socket.h>
+#include <sys/types.h>],
+[
+struct sockaddr_storage sa_store;
+],
+samba_cv_HAVE_SOCKADDR_STORAGE=yes,samba_cv_HAVE_SOCKADDR_STORAGE=no)])
+if test x"$samba_cv_HAVE_SOCKADDR_STORAGE" = x"yes"; then
+ AC_DEFINE(HAVE_SOCKADDR_STORAGE,1,[Whether the system has struct sockaddr_storage])
+fi
+
+
################################################
# look for a method of setting the effective uid
seteuid=no;