summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2010-08-06 10:21:09 +0200
committerMichael Adam <obnox@samba.org>2010-08-25 14:05:51 +0200
commit3add3aa17de7954b01e2c9273295195438ac30e5 (patch)
tree7a3aec15f6395110d420eb96c1a9accc1989b9e8 /source3/configure.in
parent896f3c8a49864ff022ac2d32a81f5b4ce53fd16b (diff)
downloadsamba-3add3aa17de7954b01e2c9273295195438ac30e5.tar.gz
samba-3add3aa17de7954b01e2c9273295195438ac30e5.tar.bz2
samba-3add3aa17de7954b01e2c9273295195438ac30e5.zip
s3:smbd: add a nfs backend for sysquotas.
This module is based on the Solaris/FreeBSD implementation of NFS quotas in the quotas.c module. It implements the SMB_USER_QUOTA_TYPE query of the get_quotas call. The other types and the set_quota call are not implemented.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 02904800a3..d8bf554387 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5025,6 +5025,27 @@ AC_MSG_CHECKING(whether to use the new lib/sysquotas.c interface)
fi
fi
+if test x"$samba_cv_SYSQUOTA_FOUND" != x"no"; then
+AC_CACHE_CHECK([whether the sys_quota interface works with NFS],samba_cv_SYSQUOTA_WORKS_NFS,[
+SAVE_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS ${SAMBA_CONFIGURE_CPPFLAGS}"
+AC_TRY_COMPILE([
+#include "confdefs.h"
+#define NO_PROTO_H 1
+#define NO_CONFIG_H 1
+#define HAVE_SYS_QUOTAS 1
+#define HAVE_NFS_QUOTAS 1
+#include "${srcdir-.}/lib/sysquotas_nfs.c"
+],[],samba_cv_SYSQUOTA_WORKS_NFS=yes,samba_cv_SYSQUOTA_WORKS_NFS=no)
+CPPFLAGS="$SAVE_CPPFLAGS"
+])
+if test x"$samba_cv_SYSQUOTA_WORKS_NFS" = x"yes"; then
+ if test x"$samba_cv_WE_USE_SYS_QUOTAS" = x"yes"; then
+ AC_DEFINE(HAVE_NFS_QUOTAS,1,[Whether nfs quota support is available])
+ fi
+fi
+fi
+
if test x"$samba_cv_SYSQUOTA_FOUND" != x"no" -a x"$samba_cv_found_xfs_header" = x"yes"; then
AC_CACHE_CHECK([whether the sys_quota interface works with XFS],samba_cv_SYSQUOTA_WORKS_XFS,[
SAVE_CPPFLAGS="$CPPFLAGS"