summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-03-09 18:51:48 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:18:32 -0500
commit3adeb4274250ec4420d9d874b07d8e688a354402 (patch)
treed783eaa54a28fe825030142ce65b7b42da1d32e7 /source3/configure.in
parent257d2e0d2a6cd4c2ea62399ec97ada46dd8c395c (diff)
downloadsamba-3adeb4274250ec4420d9d874b07d8e688a354402.tar.gz
samba-3adeb4274250ec4420d9d874b07d8e688a354402.tar.bz2
samba-3adeb4274250ec4420d9d874b07d8e688a354402.zip
r21778: Wrap calls to krb5_get_init_creds_opt_free to handle the different
calling convention in the latest MIT changes. Apparantly Heimdal is also changing to this calling convention. (This used to be commit c29c69d2df377fabb88a78e6f5237de106d5c2c5)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3e407cf5dc..6a380a1cde 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3549,6 +3549,26 @@ if test x"$with_ads_support" != x"no"; then
[Whether the krb5_ticket structure contains the kvno and enctype])
fi
+ AC_CACHE_CHECK(whether krb5_get_init_creds_opt_free takes a context argument,
+ smb_krb5_creds_opt_free_context,
+ [
+ AC_TRY_COMPILE([
+ #include <krb5.h>],
+ [
+ krb5_context ctx;
+ krb5_get_init_creds_opt *opt = NULL;
+ krb5_get_init_creds_opt_free(ctx, opt);
+ ],
+ [smb_krb5_creds_opt_free_context=yes],
+ [smb_krb5_creds_opt_free_context=no]
+ )
+ ])
+
+ if test x"$smb_krb5_creds_opt_free_context" = x"yes" ; then
+ AC_DEFINE(KRB5_CREDS_OPT_FREE_REQUIRES_CONTEXT, 1,
+ [Whether krb5_get_init_creds_opt_free takes a context argument])
+ fi
+
AC_CACHE_CHECK(whether krb5_verify_checksum takes 7 arguments, smb_krb5_verify_checksum, [
AC_TRY_COMPILE([
#include <krb5.h>],