summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-04-20 21:09:44 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:19:33 -0500
commit44f5211c170c0ddc2be23717f1ad08f5fc0b329a (patch)
tree36758905a0cdb7df1a63381d7380c77192ff78f1 /source3/configure.in
parent8a22b1f0ea81f06616a2dc41a138c5126359f009 (diff)
downloadsamba-44f5211c170c0ddc2be23717f1ad08f5fc0b329a.tar.gz
samba-44f5211c170c0ddc2be23717f1ad08f5fc0b329a.tar.bz2
samba-44f5211c170c0ddc2be23717f1ad08f5fc0b329a.zip
r22418: Support running under launchd. We abstract the method of obtaining
sockets to listen on a little, because in the launchd case these are provided for us. We also add an idle timeout so that a daemon can exit after a period of inactivity. (This used to be commit fc8589a3371d396197fae508e563f814899c2beb)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1e9fca76f5..b467388947 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -348,6 +348,35 @@ AC_ARG_WITH(selftest-prefix,
esac
])
+AC_ARG_ENABLE(launchd,
+[ --enable-launchd Support running under launchd (default=auto)])
+
+if test x"$enable_launchd" != x"no" ; then
+ AC_CACHE_CHECK([whether to include launchd support],
+ samba_cv_launchd_support,
+ [
+ AC_TRY_COMPILE(
+ [
+#include <launch.h>
+ ],
+ [
+ launchd_msg(NULL);
+ launchd_data_get_fd(NULL);
+ ],
+ samba_cv_launchd_support=yes,
+ samba_cv_launchd_support=no)
+ ])
+
+ if test x"$samba_cv_launchd_support" = x"yes" ; then
+ AC_DEFINE(WITH_LAUNCHD_SUPPORT, 1,
+ [Whether launchd support should be enabled])
+ else
+ if test x"$enable_launchd" = x"yes" ; then
+ AC_ERROR(launchd support is not available)
+ fi
+ fi
+fi
+
#################################################
# set path of samba4's smbtorture
smbtorture4_path=""