summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorKai Blin <kai@samba.org>2010-08-14 07:40:51 +0200
committerKai Blin <kai@samba.org>2010-08-21 12:05:40 +0200
commit45ac8ffdb4181c31605ccda5035664a8019ffc49 (patch)
tree37d132eabde16e2d01ab4748954fea4923fd510f /source3/configure.in
parent554b1140a891d8b9a4a7be1eefae97b4e3a710ec (diff)
downloadsamba-45ac8ffdb4181c31605ccda5035664a8019ffc49.tar.gz
samba-45ac8ffdb4181c31605ccda5035664a8019ffc49.tar.bz2
samba-45ac8ffdb4181c31605ccda5035664a8019ffc49.zip
s3: Fix netgrent configure checks for compilers not supporting -Werror-implicit-function-declaration
This should fix bug 7620.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5156159aa1..db524d5891 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6510,7 +6510,9 @@ AC_SUBST(FLAGS1)
###################################################
# Check for different/missing (set|get|end)netgrent prototypes
CFLAGS_SAVE=$CFLAGS
-CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
+if test x"$samba_cv_HAVE_Wdeclaration_after_statement" = x"yes"; then
+ CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
+fi
AC_CACHE_CHECK([for setnetgrent prototype],samba_cv_setnetgrent_prototype, [
AC_TRY_COMPILE([#include<netdb.h>
#ifdef HAVE_NETGROUP_H