summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-02-22 02:47:53 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-02-22 02:47:53 +0000
commit527aaf6def6b53c0e01fc5d8369b06be4237fca0 (patch)
tree10319b71b7c9f7e2a2fd13b520a7f7bd03390fa5 /source3/configure.in
parent34b31b529eff309d11877197b1fbc62a06f3920a (diff)
downloadsamba-527aaf6def6b53c0e01fc5d8369b06be4237fca0.tar.gz
samba-527aaf6def6b53c0e01fc5d8369b06be4237fca0.tar.bz2
samba-527aaf6def6b53c0e01fc5d8369b06be4237fca0.zip
Add the pdb_plugin module from Jelmer Vernooij <jelmer@nl.linux.org>.
This allow the user to select 'passdb backend = plugin : /path/to/plugin.so : pluging args' And load any arbitary plugin. Apparently Jelmer has a mysql plugin in the works - hence this patch. We probably need to rework the interface a bit before 3.0 (add versioning of some kind) but this is a good start. Andrew Bartlett (This used to be commit d6d18b70f0c377344b0b3d9df5a11d209793bfe0)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in33
1 files changed, 29 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 90bf8a67c5..acd043294d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -84,6 +84,13 @@ esac
AC_VALIDATE_CACHE_SYSTEM_TYPE
+DYNEXP=
+
+# I'm sure gcc supports -rdynamic
+if test "$ac_cv_prog_gcc" = yes; then
+ DYNEXP="-rdynamic"
+fi
+
#
# Config CPPFLAG settings for strange OS's that must be set
# before other tests.
@@ -91,6 +98,7 @@ AC_VALIDATE_CACHE_SYSTEM_TYPE
case "$host_os" in
# Try to work out if this is the native HPUX compiler that uses the -Ae flag.
*hpux*)
+
AC_PROG_CC_FLAG(Ae)
# mmap on HPUX is completely broken...
AC_DEFINE(MMAP_BLACKLIST)
@@ -112,6 +120,7 @@ case "$host_os" in
AC_DEFINE(USE_BOTH_CRYPT_CALLS)
;;
esac
+ DYNEXP="-Wl,-E"
;;
#
@@ -157,6 +166,7 @@ case "$host_os" in
;;
esac
else
+ DYNEXP="-dc -dp"
CPPFLAGS="$CPPFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
fi
;;
@@ -342,7 +352,7 @@ if test x"$ac_cv_lib_cups_httpConnect" = x"yes"; then
fi
############################################
-# we need libdl for PAM and the new VFS code
+# we need libdl for PAM, the password database plugins and the new VFS code
AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])
@@ -700,10 +710,12 @@ case "$host_os" in
*linux*) AC_DEFINE(LINUX)
BLDSHARED="true"
LDSHFLAGS="-shared"
+ DYNEXP="-Wl,--export-dynamic"
PICFLAG="-fPIC"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
- *solaris*) AC_DEFINE(SUNOS5)
+ *solaris*)
+ AC_DEFINE(SUNOS5)
BLDSHARED="true"
LDSHFLAGS="-h \$@ -G"
if test "${ac_cv_prog_CC}" = "gcc"; then
@@ -716,6 +728,7 @@ case "$host_os" in
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
*sunos*) AC_DEFINE(SUNOS4)
+# WL="-Qoption ld "
BLDSHARED="true"
LDSHFLAGS="-Wl,-h,\$@ -G"
PICFLAG="-KPIC" # Is this correct for SunOS
@@ -755,15 +768,20 @@ case "$host_os" in
LDSHFLAGS="-b -z +h \$@"
PICFLAG="+z"
fi
+ DYNEXP="-Wl,-E"
AC_DEFINE(STAT_ST_BLOCKSIZE,8192)
;;
*qnx*) AC_DEFINE(QNX);;
*osf*) AC_DEFINE(OSF1)
+ WL="-Wl,"
BLDSHARED="true"
LDSHFLAGS="-Wl,-soname,\$@ -shared"
PICFLAG="-fPIC"
;;
- *sco*) AC_DEFINE(SCO);;
+ *sco*)
+ DYNEXP="-Wl,-Bexport"
+ AC_DEFINE(SCO)
+ ;;
*unixware*) AC_DEFINE(UNIXWARE)
BLDSHARED="true"
LDSHFLAGS="-Wl,-soname,\$@ -shared"
@@ -777,17 +795,24 @@ case "$host_os" in
AC_DEFINE(HAVE_MEMSET)
fi
LDSHFLAGS="-G"
+ DYNEXP="-Bexport"
;;
- *mips-sni-sysv4*) AC_DEFINE(RELIANTUNIX);;
+ *mips-sni-sysv4*)
+ AC_DEFINE(RELIANTUNIX)
+ WL="-LD"
+ ;;
esac
;;
+
*sysv5*)
+ WL="-Wl,"
if [ test "$GCC" != yes ]; then
AC_DEFINE(HAVE_MEMSET)
fi
LDSHFLAGS="-G"
;;
esac
+AC_SUBST(DYNEXP)
AC_MSG_RESULT($BLDSHARED)
AC_MSG_CHECKING([linker flags for shared libraries])
AC_MSG_RESULT([$LDSHFLAGS])