summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2012-04-09 11:04:07 -0700
committerJeremy Allison <jra@samba.org>2012-04-09 21:40:40 +0200
commit5701a4d8611ad1e310b76b00b146b0902c9b34ff (patch)
treee73924791ec3c12f796836cd1827cef1561b9a97 /source3/configure.in
parent5184f41cd8f51fd426bb6b7d6fea657df44dd8a4 (diff)
downloadsamba-5701a4d8611ad1e310b76b00b146b0902c9b34ff.tar.gz
samba-5701a4d8611ad1e310b76b00b146b0902c9b34ff.tar.bz2
samba-5701a4d8611ad1e310b76b00b146b0902c9b34ff.zip
Move blksize_t and blkcnt_t to replace.h from includes.h. Should help with platforms that don't have these.
Autobuild-User: Jeremy Allison <jra@samba.org> Autobuild-Date: Mon Apr 9 21:40:42 CEST 2012 on sn-devel-104
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 98714d5dd2..bc8afc007d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2943,6 +2943,9 @@ AC_TRY_RUN([
#endif
#include <stdio.h>
#include <sys/stat.h>
+#ifndef HAVE_BLKCNT_T
+typedef long blkcnt_t;
+#endif
main() { exit((sizeof(blkcnt_t) == 4) ? 0 : 1); }],
samba_cv_SIZEOF_BLKCNT_T_4=yes,samba_cv_SIZEOF_BLKCNT_T_4=no,samba_cv_SIZEOF_BLKCNT_T_4=cross)])
if test x"$samba_cv_SIZEOF_BLKCNT_T_4" = x"yes"; then
@@ -2956,6 +2959,9 @@ AC_TRY_RUN([
#endif
#include <stdio.h>
#include <sys/stat.h>
+#ifndef HAVE_BLKCNT_T
+typedef long blkcnt_t;
+#endif
main() { exit((sizeof(blkcnt_t) == 8) ? 0 : 1); }],
samba_cv_SIZEOF_BLKCNT_T_8=yes,samba_cv_SIZEOF_BLKCNT_T_8=no,samba_cv_SIZEOF_BLKCNT_T_8=cross)])
if test x"$samba_cv_SIZEOF_BLKCNT_T_8" = x"yes"; then