summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-07-07 17:35:08 +0200
committerMichael Adam <obnox@samba.org>2008-07-07 20:34:04 +0200
commit576d1dc66d29d4a6265b3172052673cc4e5e869b (patch)
tree3aa2b5d0f1cc01a87865ac252dd92ba8dffea884 /source3/configure.in
parentbf62ddc9e668f7798625096bc880132f4abdf775 (diff)
downloadsamba-576d1dc66d29d4a6265b3172052673cc4e5e869b.tar.gz
samba-576d1dc66d29d4a6265b3172052673cc4e5e869b.tar.bz2
samba-576d1dc66d29d4a6265b3172052673cc4e5e869b.zip
build: set SONAME version of libraries from configure, not using library-versions
This sets the library versions (previously gotten from library-versions file during make) already at configure time. For library "foo", the version is stored in the LIBFOO_SOVER configure variable. For all libraries except libwbclient, this is done through the call of SMB_LIBRARY(). NOTE: Currently the versions are hard-coded in the SMB_LIBRARY() calls in configure.in, but this change makes it easier to retrieve the version from the libraries source dir at configure time, e.g. for talloc and tdb. Michael (This used to be commit 3c300f9f8cffb5af32e291ec75007ab98fe96561)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in21
1 files changed, 15 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 673bf3b91e..8d89fe50a3 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -86,6 +86,7 @@ AC_SUBST(LIBWBCLIENT_SHARED_TARGET)
AC_SUBST(LIBWBCLIENT_SHARED)
AC_SUBST(LIBWBCLIENT_STATIC_TARGET)
AC_SUBST(LIBWBCLIENT_STATIC)
+AC_SUBST(LIBWBCLIENT_SOVER)
AC_SUBST(LIBWBCLIENT)
AC_SUBST(WINBIND_LIBS)
@@ -4673,12 +4674,19 @@ LINK_LIBNETAPI=STATIC
LINK_LIBSMBCLIENT=STATIC
-SMB_LIBRARY(talloc)
-SMB_LIBRARY(tdb)
-SMB_LIBRARY(netapi)
-SMB_LIBRARY(smbclient)
-SMB_LIBRARY(smbsharemodes)
-SMB_LIBRARY(addns, no, [undefined API])
+#
+# The library versions are hardcoded here
+# and filled into the LIBFOO_SOVER variable.
+#
+# TODO: for talloc and tdb (at least), these should
+# be extracted from their respective source directories
+#
+SMB_LIBRARY(talloc, 1)
+SMB_LIBRARY(tdb, 1)
+SMB_LIBRARY(netapi, 0)
+SMB_LIBRARY(smbclient, 0)
+SMB_LIBRARY(smbsharemodes, 0)
+SMB_LIBRARY(addns, 0, no, [undefined API])
@@ -5615,6 +5623,7 @@ fi
LIBWBCLIENT_SHARED_TARGET=bin/libwbclient.$SHLIBEXT
LIBWBCLIENT_STATIC_TARGET=bin/libwbclient.a
+LIBWBCLIENT_SOVER=0
if test $BLDSHARED = true -a x"$HAVE_WINBIND" = x"yes" -a x"$BUILD_LIBWBCLIENT_SHARED" = x"yes"; then
NSS_MODULES="${WINBIND_NSS} ${WINBIND_WINS_NSS}"
## Only worry about libwbclient if we have shared library support