summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2010-11-24 10:06:38 +1100
committerAndrew Tridgell <tridge@samba.org>2010-11-24 00:19:15 +0100
commit57f9de012e891feb75b40a58d16cf0f63fd158c1 (patch)
treecd0a9fe3e80e6bb4179e42d3c483c7bb32da50eb /source3/configure.in
parent93d311c07e0b38193f823515b068e87dec144312 (diff)
downloadsamba-57f9de012e891feb75b40a58d16cf0f63fd158c1.tar.gz
samba-57f9de012e891feb75b40a58d16cf0f63fd158c1.tar.bz2
samba-57f9de012e891feb75b40a58d16cf0f63fd158c1.zip
s3-torture: remove the merged_build tests for building smbtorture4
s3 now builds smbtorture4 if the required packages (perl, python, ads) are available. This should ensure that smbtorture4 is built in the build farm when possible
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in33
1 files changed, 6 insertions, 27 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f5a39ad79f..011bd1afec 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -197,7 +197,7 @@ AC_ARG_WITH(profiling-data,
)
dnl Checks for programs.
-merged_build_possible=yes
+smbtorture4_possible=yes
AC_PROG_INSTALL
AC_PROG_AWK
@@ -207,11 +207,11 @@ AC_SAMBA_GNU_MAKE([true], [true])
# Check for perl
m4_include(../m4/check_perl.m4)
-AC_SAMBA_PERL([true], [merged_build_possible=no])
+AC_SAMBA_PERL([true], [smbtorture4_possible=no])
# Check for python
m4_include(../m4/check_python.m4)
-AC_SAMBA_PYTHON_DEVEL([true], [merged_build_possible=no])
+AC_SAMBA_PYTHON_DEVEL([true], [smbtorture4_possible=no])
AC_CHECK_TOOL(AR, ar)
@@ -1986,7 +1986,7 @@ if test x"$BLDSHARED" != x"true"; then
SHLD="shared-libraries-disabled"
PICFLAG="${PIE_CFLAGS}"
SHLIBEXT="shared_libraries_disabled"
- merged_build_possible=no
+ smbtorture4_possible=no
fi
AC_MSG_CHECKING([used PICFLAG])
@@ -4408,7 +4408,7 @@ LIBS="$ac_save_LIBS"
fi
if test x"$use_ads" != xyes; then
- merged_build_possible=no
+ smbtorture4_possible=no
fi
AC_CHECK_LIB_EXT(nscd, NSCD_LIBS, nscd_flush_cache)
@@ -6896,30 +6896,9 @@ MSG
fi
-AC_ARG_ENABLE(merged-build,
-[AS_HELP_STRING([--enable-merged-build], [Build Samba 4 as well])],
-[ enable_merged_build=$enableval ], [ enable_merged_build=auto ])
-
-if test x"$enable_merged_build" = x"yes" -a \
- x"$merged_build_possible" = x"no" ; then
- AC_MSG_ERROR(Merged build required but not possible)
-fi
-
m4_include(../lib/zlib/zlib.m4)
-if test x$enable_merged_build = xauto; then
-
- AC_MSG_CHECKING([whether it would be possible to do a merged build])
- AC_MSG_RESULT([$merged_build_possible])
-
- # Enable merged build automatically if possible, when in developer mode
- if test "x$developer" = xyes; then
- enable_merged_build=$merged_build_possible
- fi
-fi
-
-if test x$enable_merged_build = xyes; then
- MERGED_BUILD=1
+if test x$smbtorture4_possible = xyes; then
saved_USESHARED="$USESHARED"
USESHARED="false"
smbtorture4_path="bin/smbtorture4"