summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2007-12-15 23:22:25 -0800
committerJeremy Allison <jra@samba.org>2007-12-15 23:22:25 -0800
commit5dbc4a23bcae0087ab4319b5343cf6f44a4819e3 (patch)
tree54a1891614465507a58f318e5b8853ce897736bc /source3/configure.in
parent0b33d60affc321d549178b78a39e9df910dfe74f (diff)
downloadsamba-5dbc4a23bcae0087ab4319b5343cf6f44a4819e3.tar.gz
samba-5dbc4a23bcae0087ab4319b5343cf6f44a4819e3.tar.bz2
samba-5dbc4a23bcae0087ab4319b5343cf6f44a4819e3.zip
Added patch originally by Andreas Schneider <anschneider@suse.de>
to cause us to behave like Vista when looking for remote machine principal. Modified by me. Jeremy. (This used to be commit d0e33840fb4cfc85990d3ee327428b0854a22722)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7272ae4d9a..ac60b6f645 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -4221,6 +4221,30 @@ if test x"$with_ads_support" != x"no"; then
fi
fi
+ AC_CACHE_CHECK([for krb5_principal_get_realm],
+ samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM,[
+ AC_TRY_LINK([#include <krb5.h>],
+ [krb5_context ctx = NULL; krb5_principal princ = NULL; const char *str = krb5_principal_get_realm(ctx, princ);],
+ samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM=yes,
+ samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_PRINCIPAL_GET_REALM" = x"yes"; then
+ AC_DEFINE(HAVE_KRB5_PRINCIPAL_GET_REALM,1,
+ [Whether the function krb5_principal_get_realm is defined])
+ fi
+
+ AC_CACHE_CHECK([for krb5_princ_realm],
+ samba_cv_HAVE_KRB5_PRINC_REALM,[
+ AC_TRY_LINK([#include <krb5.h>],
+ [krb5_context ctx = NULL; krb5_principal princ = NULL; const char *str = krb5_princ_realm(ctx, princ)->data;],
+ samba_cv_HAVE_KRB5_PRINC_REALM=yes,
+ samba_cv_HAVE_KRB5_PRINC_REALM=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_PRINC_REALM" = x"yes"; then
+ AC_DEFINE(HAVE_KRB5_PRINC_REALM,1,
+ [Whether the macro krb5_princ_realm is defined])
+ fi
+
#
#
# Now the decisions whether we can support krb5