summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBjörn Jacke <bj@sernet.de>2010-08-12 16:18:45 +0200
committerBjörn Jacke <bj@sernet.de>2010-08-12 16:30:35 +0200
commit616e187d68e3e7b202413a96518b31d029e9563a (patch)
treec4d087133c8f6ea4b5c1c44460a2f8e0eceb78ea /source3/configure.in
parent1d443f6bc251303e827e97401771a66c03fc33e7 (diff)
downloadsamba-616e187d68e3e7b202413a96518b31d029e9563a.tar.gz
samba-616e187d68e3e7b202413a96518b31d029e9563a.tar.bz2
samba-616e187d68e3e7b202413a96518b31d029e9563a.zip
s3: fall back to cups-config for underlinked libs
some OpenBSD systems have underlinked cups libraries. If linking against cups alone fails, try to link against all the cups-config --libs cruft, which we usually don't want. (bugzila #7244)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 10 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4b92cd677e..0023fe2a69 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -813,15 +813,21 @@ if test x$enable_cups != xno; then
if test "x$CUPS_CONFIG" != x; then
- ac_save_CFLAGS=$CFLAGS
ac_save_LDFLAGS=$LDFLAGS
ac_save_PRINT_LIBS=$PRINT_LIBS
- CFLAGS="$CFLAGS `$CUPS_CONFIG --cflags`"
- LDFLAGS="$LDFLAGS `$CUPS_CONFIG --ldflags`"
- PRINT_LIBS="$PRINT_LIBS -lcups"
AC_CHECK_HEADERS(cups/cups.h cups/language.h)
+
if test x"$ac_cv_header_cups_cups_h" = xyes -a \
x"$ac_cv_header_cups_language_h" = xyes; then
+ # try linking with -lcups alone first. That should work unless libcups is
+ # underlinked. With cups-config --libs we pull in unwanted and unneeded
+ # dendencies including thread libraries - use cups-config only if really
+ # required.
+ AC_CHECK_LIB_EXT(cups, ac_save_PRINT_LIBS , httpConnect,
+ [PRINT_LIBS"$ac_save_PRINT_LIBS -lcups"],
+ [AC_MSG_WARN([your cups library doesn't link with -lcups alone, it might be underlinked.]) ;
+ PRINT_LIBS="$ac_save_PRINT_LIBS `$CUPS_CONFIG --libs`"])
+
AC_DEFINE(HAVE_CUPS,1,[Whether we have CUPS])
samba_cv_HAVE_CUPS=yes
AC_CHECK_LIB_EXT(cups, PRINT_LIBS, httpConnectEncrypt)