summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2001-09-19 09:44:12 +0000
committerAndrew Bartlett <abartlet@samba.org>2001-09-19 09:44:12 +0000
commit6794b58a8c5941ede29e07247bda911328cd7b20 (patch)
treec57ea30d76a3b5d3c08cde0785ce42a86e873439 /source3/configure.in
parentebe02a7e8743e413113562150f40e7db3d2d378c (diff)
downloadsamba-6794b58a8c5941ede29e07247bda911328cd7b20.tar.gz
samba-6794b58a8c5941ede29e07247bda911328cd7b20.tar.bz2
samba-6794b58a8c5941ede29e07247bda911328cd7b20.zip
Add the ability to display Samba's build options with smbd -b and as a level 4
DEBUG(). Also included are details like build date/time, location and compiler. This should get most of the options we set, except those that don't affect smbd, like WITH_PAM_SMBPASSWD or WITH_WINBINDD. This work due to Vance Lankhaar <vlankhaar@hotmail.com> Some work needs to be done to make it only rebuild when needed (ie smbd being rebuilt) but its in pretty good shape already. Also fix up some printf() -> d_printf(). Andrew Bartlett (This used to be commit beff1d2beaf4337dba6bfc372c5e09a43cfd791a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 467eba7098..5ccaeb756f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1046,6 +1046,7 @@ AC_ARG_WITH(libiconv,
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
AC_CHECK_LIB(iconv, iconv_open)
+ AC_DEFINE_UNQUOTED(WITH_LIBICONV, "${withval}")
;;
esac ],
AC_MSG_RESULT(no)
@@ -1582,6 +1583,7 @@ AC_ARG_WITH(krb4,
LIBS="$LIBS -lkrb -ldes"
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
+ AC_DEFINE_UNQUOTED(KRB4_DIR, ${withval})
;;
*)
AC_MSG_RESULT(no)
@@ -1602,6 +1604,7 @@ AC_ARG_WITH(krb5,
LIBS="$LIBS -ldes425 -lkrb5 -lcrypto -lcom_err"
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
+ AC_DEFINE_UNQUOTED(KRB5_DIR,${withval})
;;
*)
AC_MSG_RESULT(no)
@@ -1818,11 +1821,13 @@ AC_ARG_WITH(ssl,
CFLAGS="-I/usr/local/ssl/include $CFLAGS"
LIBS="-lssl -lcrypto $LIBS"
LDFLAGS="=L/usr/local/ssl/lib $LDFLAGS"
+ AC_DEFINE(SSL_DIR, "/usr/local/ssl")
;;
* )
CFLAGS="-I${withval} $CFLAGS"
LIBS="-lssl -lcrypto $LIBS"
LDFLAGS="-L${withval}/lib $LDFLAGS"
+ AC_DEFINE_UNQUOTED(SSL_DIR, "${withval}", Used for determining the compile time options)
;;
esac
@@ -1831,9 +1836,10 @@ AC_ARG_WITH(ssl,
CFLAGS="-I/usr/local/ssl/include $CFLAGS"
LIBS="-lssl -lcrypto $LIBS"
LDFLAGS="-L/usr/local/ssl/lib $LDFLAGS"
+ AC_DEFINE(SSL_DIR, "/usr/local/ssl")
fi
-
+
if test ! -d ${withval}; then
echo "configure: error: called with --with-ssl, but ssl base directory ${withval} does not exist or is not a directory. Aborting config" 1>&2
exit 1
@@ -1895,6 +1901,7 @@ AC_ARG_WITH(quotas,
yes)
AC_MSG_RESULT(yes)
QUOTAOBJS=smbd/quotas.o
+ AC_DEFINE(WITH_QUOTAS)
;;
*)
AC_MSG_RESULT(no)
@@ -2331,7 +2338,6 @@ if test x"$HAVE_WINBIND" = x"yes"; then
WINBIND_TARGETS="\$(WINBIND_PROGS)"
WINBIND_STARGETS="\$(WINBIND_SPROGS)"
WINBIND_LTARGETS="\$(WINBIND_LPROGS)"
-
case "$with_pam" in
yes)
WINBIND_PAM_PROGS="\$(WINBIND_PAM_PROGS)"