summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2011-03-31 15:39:41 +0200
committerMichael Adam <obnox@samba.org>2011-03-31 18:10:22 +0200
commit69aead60e27695d19aeda6226a91e1358d070f03 (patch)
tree62174abebbf781892b2f04afb158a6b84d7eb204 /source3/configure.in
parente9e23cc948f88974c94b3221fc65be093197bcb2 (diff)
downloadsamba-69aead60e27695d19aeda6226a91e1358d070f03.tar.gz
samba-69aead60e27695d19aeda6226a91e1358d070f03.tar.bz2
samba-69aead60e27695d19aeda6226a91e1358d070f03.zip
s3:configure: add check for new CTDB_CONTROL_SCHEDULE_FOR_DELETION
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 0b479dd465..291bc0642c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5480,6 +5480,25 @@ if test "x$have_cluster_support" = "xyes" ; then
fi
if test "x$have_cluster_support" = "xyes" ; then
+ AC_HAVE_DECL(CTDB_CONTROL_SCHEDULE_FOR_DELETION,[
+ #include "confdefs.h"
+ #define NO_CONFIG_H
+ #include "replace.h"
+ #include "system/wait.h"
+ #include "system/network.h"
+ #include <talloc.h>
+ #include <tdb.h>
+ #include <ctdb.h>
+ #include <ctdb_private.h>
+ ])
+ if test x"$ac_cv_have_CTDB_CONTROL_SCHEDULE_FOR_DELETION_decl" != x"yes"
+ then
+ ctdb_broken="support for SCHEDULE_FOR_DELETION control missing"
+ have_cluster_support=no
+ fi
+fi
+
+if test "x$have_cluster_support" = "xyes" ; then
# In ctdb 1.0.57, ctdb_control_tcp was temporarily renamed
# to ctdb_tcp_client.
AC_CHECK_TYPE(struct ctdb_tcp_client,[