summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2004-09-21 01:37:34 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:52:44 -0500
commit73d82994fb1d6b5bbb33583d6e542968478f1238 (patch)
tree926c46be0972c22f7f83170fff282a89c3512402 /source3/configure.in
parent1d886507be8f5bf44fc0228a7d8bc5ce9be2e142 (diff)
downloadsamba-73d82994fb1d6b5bbb33583d6e542968478f1238.tar.gz
samba-73d82994fb1d6b5bbb33583d6e542968478f1238.tar.bz2
samba-73d82994fb1d6b5bbb33583d6e542968478f1238.zip
r2453: I think this is the last lot of fixes to get shared libraries working on
HPUX. This is Richard Allen's suggestion to get HPUX to use cc instead of ld. Also he added some missing $(DYNEXP) on link lines and removed the definition of $(LINK) as it is no longer used in the Makefile. (This used to be commit 9481f2a79e83b0dae9141f65ccc59e59bcf682e7)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a2c0d981fd..69152d8fc8 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1214,9 +1214,9 @@ if test "$enable_shared" = "yes"; then
# Use special PIC flags for the native HP-UX compiler.
if test $ac_cv_prog_cc_Ae = yes; then
BLDSHARED="true"
- SHLD="/usr/bin/ld"
- LDSHFLAGS="-B symbolic -b -z"
- SONAMEFLAG="+h "
+ SHLD="cc"
+ LDSHFLAGS="-b -Wl,-B,symbolic,-b,-z"
+ SONAMEFLAG="-Wl,+h "
PICFLAGS="+z"
elif test "${GCC}" = "yes"; then
PICFLAGS="-fPIC"