summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2005-03-25 14:37:10 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:56:19 -0500
commit78a3af6233627b7257c40ca040001bee6c6f9b3e (patch)
treecd47bd464d0e51b30378d9fc374f32d26ef41c7b /source3/configure.in
parent9dba95788071d22f90d222f5a2440d0442d55385 (diff)
downloadsamba-78a3af6233627b7257c40ca040001bee6c6f9b3e.tar.gz
samba-78a3af6233627b7257c40ca040001bee6c6f9b3e.tar.bz2
samba-78a3af6233627b7257c40ca040001bee6c6f9b3e.zip
r6062: work around autoconf setting the CFLAGS="-g -O2" by default in AC_CACHE_CHECK
(This used to be commit 605dd5b97c09fd3e6bc09eefa78ef333201c0b7c)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 10 insertions, 7 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 72a04375a2..9b2f4b80ce 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -235,6 +235,16 @@ AC_ARG_ENABLE(debug,
CFLAGS="${CFLAGS} -g"
fi])
+# compile with optimization and without debugging by default, but
+# allow people to set their own preference.
+# do this here since AC_CACHE_CHECK apparently sets the CFLAGS to "-g -O2"
+# if it has no value. This prevent *very* large debug binaries from occurring
+# by default.
+if test "x$CFLAGS" = x; then
+ CFLAGS="-O"
+fi
+
+
AC_ARG_ENABLE(developer, [ --enable-developer Turn on developer warnings and debugging (default=no)],
[if eval "test x$enable_developer = xyes"; then
developer=yes
@@ -293,13 +303,6 @@ AC_PATH_PROG(PERL, perl)
AC_CHECK_TOOL(AR, ar)
-# compile with optimization and without debugging by default, but
-# allow people to set their own preference.
-if test "x$CFLAGS" = x
-then
- CFLAGS="-O ${CFLAGS}"
-fi
-
dnl Check if we use GNU ld
LD=ld
AC_PROG_LD_GNU